Technical issue: Company Formation

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 13:16 GMT

Identified

When: Monday, 9 March

You may experience delays when registering your company – this is due to a technical issue.

Please stay patient – we're actively working with Companies House to sort this out.

We'll update here once this is resolved.

If you need urgent help, email hello@tide.co – we’ll be there.

We apologise for the inconvenience.
Posted Mar 09, 2026 - 11:28 GMT