Degraded Performance - Direct Debits

Incident Report for Tide

Resolved

Incident was resolved.
Posted Feb 02, 2024 - 11:12 GMT

Investigating

You might not be able to use the ‘Direct Debits’ tab at the moment.

We’re looking into the cause of this, and we apologise for any inconvenience.

If you have an urgent query in relation to a Direct Debit, tap ‘Support’ in the app.
Posted Feb 02, 2024 - 10:29 GMT
This incident affected: UK Tide App and UK Tide on the Web.