Payment services issue

Incident Report for Tide

Resolved

Payment services are back to normal

We've resolved the issue that was causing your outbound payments to fail.

Your recipient details should also now appear correctly on your timeline.

Thanks for your patience while we were working on this.
Posted Mar 31, 2026 - 13:45 BST

Investigating

Your payments are missing your recipient details

Some Outbound Payments are failing

We’re fixing this

Please check back here for updates – we’ll let you know as soon as payments are back to normal.

For urgent queries, tap ‘Support’ in the app.

We apologise for any inconvenience you’re experiencing at this time.
Posted Mar 31, 2026 - 13:04 BST