Issue: Post Office deposits

Incident Report for Tide

Resolved

Resolved: Post Office deposits

You can now make deposits at the Post Office and PayPoint again.

Once again, we appreciate your patience.
Posted Nov 05, 2025 - 15:10 GMT

Investigating

You may not be able to make a deposit at the Post Office at the moment.

We’re already working to resolve this – please check back here for updates.

Thanks for your patience, and we're sorry for any inconvenience.

For anything urgent, tap 'Support' in the app.
Posted Nov 05, 2025 - 14:23 GMT