Company Formation unavailable

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 09:45 GMT

Identified

Due to a planned maintenance in Companies House, members will not be able to use the Company Formation flow until 9am Monday 02.02.2026.
Posted Feb 01, 2026 - 09:32 GMT