Degraded performance

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 07:33 BST

Update

We are continuing to work on a fix for this issue.
Posted Apr 22, 2025 - 07:29 BST

Identified

One of our service providers is experiencing an issue that is affecting some of Tide's functionalities. Member's might be facing issues when using Payment Links, Tap2Pay and Card Reader Payments. Additionally Add Money via Credit or Debit cards is not functional as well.

We'll provide an update here as soon as the services have been restored.

For urgent queries, tap ‘Support’ in the app, or email hello@tide.co.

We apologise for the inconvenience.
Posted Apr 21, 2025 - 20:30 BST