Issues with 'Add Money' via 'Cards'

Incident Report for Tide

Resolved

We've resolved this issue, and you can now 'Add Money' via 'Cards' again.
Sorry for the inconvenience.
Posted Apr 30, 2025 - 10:54 BST

Investigating

You're currently unable to 'Add Money' via 'Cards' due to a temporary technical issue.
We're working to resolve this as soon as possible.
Posted Apr 29, 2025 - 17:15 BST