This maintenance has been postponed by a partner. We will announce the new dates as soon as they become available.
Posted Sep 05, 2024 - 16:53 BST
Scheduled
Faster Payments in and out, will be queued during this window. Please, do not reattempt pending payments - they will go through normally after the maintenance.
If your payment hasn’t arrived after the maintenance window, tap ‘Support’ in your app to contact us.
Posted Sep 05, 2024 - 09:30 BST
This scheduled maintenance affected: Making Payments (UK).