Transactions aren't showing

Incident Report for Tide

Resolved

We've resolved the issue that was preventing you from viewing your transactions.

Your transactions view should be back to normal

Thanks for your patience while we were working on this.
Posted Apr 01, 2026 - 21:51 BST

Investigating

We're experiencing an issue that may prevent you from viewing your transactions.

If your transactions are not showing, please don't repeat any payments for the time being.

We're resolving this as fast as possible.

For urgent balance queries, tap 'Support' in your app. "
Posted Apr 01, 2026 - 21:42 BST