Error

Incident Report for Tide

Resolved

This issue has now been resolved and all functionalities have been resolved.
Posted Dec 19, 2024 - 16:38 GMT

Identified

Inbound Payments aren’t showing on members’ timelines. They’re held in a queue, and will appear when the issue is resolved.

We’re fixing this

Please check back here for updates – we’ll let you know as soon as payments are back to normal.

For urgent queries, tap ‘Support’ in the app.

We apologise for any inconvenience you’re experiencing at this time.
Posted Dec 19, 2024 - 14:05 GMT
This incident affected: Making Payments (UK).