Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 14, 2024 - 22:40 BST
Scheduled
Outgoing payments made between 22:40 BST 14 September to 14:20 BST 15 September will be queued until the maintenance is complete.
Please only make a payment once during this time, as it will be processed normally after this window. Inbound payments may face delays in reaching your account.
If you have any urgent payments to make, please make them before this time. If your payment hasn't arrived after this maintenance window, tap 'Support' in your app to contact us.
Posted Sep 12, 2024 - 14:50 BST
This scheduled maintenance affected: Making Payments (UK).