Technical issue: Delays in company registration

Incident Report for Tide

Resolved

Resolved issue: Company registration
You can now proceed with your company registration application via Tide as usual.
If you see an error message, simply tap Retry or exit and re-open your Tide app. You can then verify your identity and continue with your company registration.
Thank you for your patience while we fixed this.
If you’ve got any questions about your application, tap Support in the app and we’ll be happy to help.
Posted Mar 24, 2026 - 14:15 GMT

Investigating

When: Tuesday, 24 March
We're currently experiencing a technical issue that is preventing you from completing your personal identification, when registering your company.
Your application may be queued, so don't reattempt to start a new one.
We're working to resolve this and will update this page when you can log in again.
Apologies for the inconvenience.
If you need urgent help, email hello@tide.co – we’ll be there.
Posted Mar 24, 2026 - 11:30 GMT