Degraded Performance - Tide

Incident Report for Tide

Resolved

We have fixed the issue and the platform remains fully stable.

We apologise for any inconvenience.
Posted Jul 11, 2024 - 17:40 BST

Investigating

We’re experiencing issues with some of our app services including Outbound Payments.

Failed payments are not being held in a queue, so you may attempt them again. Please check back here to see when this issue has been fully resolved.

For urgent queries, tap ‘Support’ in the app.

We apologise for any inconvenience.
Posted Jul 11, 2024 - 16:03 BST
This incident affected: UK Tide App, UK Tide on the Web, Making Payments (UK), and New Member Sign-up (UK).