Outage - Tide

Incident Report for Tide

Resolved

The issue has been found and fixed!
Posted Aug 12, 2025 - 12:00 BST

Identified

We're experiencing an outage affecting our Tide platform.

You may be unable to login or experience issues with core functionality.

We are currently working to restore the service to you as soon as possible.
Posted Aug 12, 2025 - 11:38 BST