Payment delays

Incident Report for Tide

Resolved

We have now restored the Payments service. You should now be able to make transfers without delays.

We apologise for this impact on your Tide experience, thank you for your patience.
Posted Aug 02, 2026 - 13:35 BST

Investigating

We're experiencing an issue affecting our Payments function - payments are being queued and will go through with a slight delay.

Please do not re-attempt payments.

We’re fixing this as quickly as we can -- apologies for any inconvenience.

If you have any questions, tap ‘Support’ in the app.
Posted Aug 02, 2026 - 12:29 BST