App log-in issues

Incident Report for Tide

Resolved

The issue has been resolved and all Members should be able to log in without any issues.

Thank you for your patience. We apologise for any inconvenience this may have caused.
Posted Sep 16, 2025 - 09:57 BST

Identified

We're experiencing an issue that's preventing some members from logging into the Tide app.

We're working to resolve this and will update this page when you can log in again.

Apologies for the inconvenience.

If you need urgent support, email tap Support in the app or hello@tide.co, and we'll help you.
Posted Sep 16, 2025 - 07:22 BST