Delay in inbound payments
Incident Report for Tide
Resolved
The issue is resolved and all inbound payments should reflect on your timeline as expected!
Posted Nov 17, 2024 - 14:21 GMT
Update
We are continuing to investigate this issue.
Posted Nov 17, 2024 - 13:19 GMT
Investigating
We are experiencing a technical problem which is affecting inbound payments.

We will post further updates here.
Posted Nov 17, 2024 - 13:14 GMT
This incident affected: UK Tide App and UK Tide on the Web.