Error
Incident Report for Tide
Resolved
Issue is now resolved
Posted Nov 17, 2023 - 12:34 GMT
Investigating
We’re experiencing an issue that may prevent your account balance from updating.
If your balance is not updating, please don’t repeat any payments for the time being.
We’re resolving this as fast as possible.
For urgent balance queries, tap ‘Support’ in your app.
Posted Nov 17, 2023 - 09:34 GMT
This incident affected: UK Tide App.