Degraded Performance - New Member Signup
Incident Report for Tide
Resolved
We have now restored the New Member Signup process. You should now be able to create a new account with Tide.

We apologise for this impact on your Tide experience, thank you for your patience.
Posted Jun 09, 2021 - 06:50 BST
Investigating
We're experiencing an issue affecting our New Member Signup process.

We are currently looking into the issue.
Posted Jun 09, 2021 - 06:48 BST
This incident affected: New Member Sign-up (UK).