Pending payments

Incident Report for Tide

Resolved

Outbound and Inbound payments should be back to normal.
Posted Jul 19, 2025 - 21:17 BST

Update

Currently outbound payments are handled - should go as normal. Impact is only on inbound payments now - they are still pending.
Posted Jul 19, 2025 - 18:30 BST

Investigating

We are currently experiencing an issue with pending payments. We are looking into this and will update here as soon as we fix this.
If you have any urgent queries, tap ‘Support’ in the app and we’ll help you.
Posted Jul 19, 2025 - 17:03 BST