Issue with EUR and USD payments

Incident Report for Tide

Resolved

We’ve fixed the technical issues related to EUR and USD payments.

You’re now able to activate EUR and USD payments in your account, and make payments in EUR and USD as you would normally.

Thank you for your patience.
Posted Apr 02, 2026 - 14:55 BST

Investigating

We’re currently facing technical difficulties involving EUR and USD payments.

If you haven’t activated these payments for your account yet, you’re currently unable to activate them.

If you have activated these payments, you’re currently unable to send them, but you can receive them.

We’re working to resolve this as quickly as possible, and will provide an update when it’s fixed.
Posted Apr 02, 2026 - 13:47 BST