Inbound and outbound payments delay

Incident Report for Tide

Resolved

Inbound and outbound payments were slightly delayed, but are now going through normally.

Thanks for giving us the time to resolve this.
Posted Aug 21, 2026 - 10:59 BST

Investigating

We’re experiencing an issue with inbound and outbound payments - they're being queued and will go through with a slight delay.

We’re fixing this as quickly as we can -- apologies for any inconvenience.

If you have any questions, tap ‘Support’ in your app and our team will support you
Posted Aug 21, 2026 - 10:54 BST