Subscriptions and refund issues

Incident Report for Tide

Resolved

We’ve resolved the issue that was impacting subscriptions and refunds.
You can now subscribe, view your details, and continue to enjoy your tools, boosts, or paid plan.
All refund requests should now go through as normal.
Thank you for your patience while we fixed this.
We apologise for any inconvenience.
Posted Apr 01, 2026 - 10:38 BST

Investigating

We're currently experiencing an issue that is impacting subscriptions to Tide. Some members aren’t able to subscribe, view, or use their tools, boosts, or paid plans.
This issue is also affecting our ability to process refund requests.
We’re fixing this
Please check back here for updates – we’ll let you know as soon as subscriptions and refunds are back to normal.
For urgent queries, tap ‘Support’ in the app.
We apologise for any inconvenience you’re experiencing at this time.
Posted Apr 01, 2026 - 10:14 BST