Error
Incident Report for Tide
Resolved
Resolved: Inbound payments delay
Posted Jan 14, 2025 - 12:15 GMT
Update
Inbound Payments were delayed, but are now going through normally.

Thanks for giving us the time to resolve this.
Posted Jan 14, 2025 - 11:56 GMT
Identified
Inbound Payments are being delayed.

These payments are being held in a queue and will soon go through normally.

Please check back here for updates on this issue.

For urgent queries, tap ‘Support’ in the app.

We apologise for any inconvenience you might experience at this time.
Posted Jan 14, 2025 - 11:51 GMT
This incident affected: UK Tide App and UK Tide on the Web.