Error

Incident Report for Tide

Resolved

The issue has been resolved.
Posted Mar 12, 2025 - 16:42 GMT

Identified

We’re currently facing a technical issue, which means we can’t respond to emails or calls at this time.
If you need support, please contact us through your Tide app by tapping ‘Support’ > ‘Messages’ and our team will be on hand to help.
We’re working to fix this issue, and will update you when it’s resolved.
Thank you for your patience and understanding.
Posted Mar 12, 2025 - 16:37 GMT
This incident affected: Member Support (UK).