Onboarding and account recovery for Tide UK is currently unavailable

Incident Report for Tide

Resolved

Issue resolve: Onboarding and account recovery for Tide UK.

You can now recover your account or create a new one normally.

Thank you for giving us the time to resolve this.
Posted Jul 01, 2025 - 10:35 BST

Investigating

You may not be able to create a new account or recover an existing one.

We're fixing this

As soon as we resolve the issue, we’ll confirm on this page.

We're sorry for the inconvenience.

Tap 'Support' in the app or email hello@tide.co if you need urgent help.
Posted Jul 01, 2025 - 09:18 BST