Error
Incident Report for Tide
Resolved
The outage has been resolved and cheques can be deposited without any issues.
Posted Jul 19, 2024 - 16:34 BST
Identified
ClearBank’s partner - Crowdstrike, is experiencing an outage affecting some of our services.

Affected service: Digital cheque deposits are failing.

Please don’t try to deposit cheques until the Crowdstrike outage is resolved. We will continue to update this page with progress on the issue.

If you require help - tap ‘Support’ in the app.

Thank you for your patience.
Posted Jul 19, 2024 - 10:39 BST
This incident affected: Making Payments (UK).