EUR & USD payments unavailable

Incident Report for Tide

Resolved

The issue was resolved on 2025-07-29 at 11:05.
Posted Jul 30, 2025 - 09:40 BST

Identified

The issue is still occurring for a some.
We update again once a full resolution is in place.
Posted Jul 29, 2025 - 11:02 BST

Monitoring

The issue seems to have been resolved.
We are monitoring the situation.
Posted Jul 29, 2025 - 11:00 BST

Identified

We’re experiencing issues with outbound EUR & USD payments.

Failed payments are not being held in a queue, so you may attempt them again. Please check back here to see when this issue has been fully resolved.

For urgent queries, tap ‘Support’ in the app.
We apologise for any inconvenience.
Posted Jul 29, 2025 - 10:43 BST