Delay in outbound payments
Incident Report for Tide
Resolved
This incident has been resolved.
Posted Jun 29, 2024 - 14:31 BST
Monitoring
We are currently processing the queued payments.
Posted Jun 28, 2024 - 14:21 BST
Investigating
Members may currently experience delays in outbound payments. We have identified the cause and are looking to fix the issue as soon as possible.

Please do not retry payments until this is resolved.
Posted Jun 28, 2024 - 12:40 BST
This incident affected: Making Payments (UK).