Connectivity issues with 159

Incident Report for Tide

Resolved

The issue has been resolved.

Thank you for your patience.
Posted Nov 05, 2025 - 15:11 GMT

Investigating

We are experiencing issues with the 159 fraud reporting number.

Please use Tides chat support in the app or mail us on hello@tide.co if this happens to you!
Posted Nov 05, 2025 - 00:00 GMT