Degraded Performance - Tide
Incident Report for Tide
Resolved
We have now restored the Tide service. You should now be able to login and use Tide as usual.

We apologise for this impact on your Tide experience, thank you for your patience.
Posted Jan 19, 2023 - 11:03 GMT
Update
We're experiencing an outage affecting our Member Support function.

You may be unable to contact our Member Support team at this time and they will have the same issue contacting you.

We are currently working to restore this service to you as soon as possible.
Posted Jan 19, 2023 - 10:57 GMT
Investigating
We're experiencing an issue affecting our Tide platform.

You may be experiencing problems using the application.

We are currently looking into the issue.
Posted Jan 19, 2023 - 10:56 GMT
This incident affected: Tide App and Tide on the Web.