Error: Member Support delays
Incident Report for Tide
Resolved
Issue has been resolved.
Posted Apr 15, 2024 - 17:54 BST
Investigating
We are experiencing a technical problem which is affecting our in-app chat. Because of this we may not be able to respond to you as fast as we'd like. We're sorry about any delays you might experience.
Posted Apr 15, 2024 - 14:17 BST
This incident affected: Member Support (UK).