Error

Incident Report for Tide

Resolved

Card details should now be visible in the app again. We apologise for any inconvenience this may have caused.
Posted May 13, 2025 - 16:42 BST

Identified

Current issue: Members are currently unable to view card details in the Tide app.

Payments are unaffected and Tide cards are working as normal.

Resolution: We’re working quickly to fix this; however, we can’t yet advise when details will be available again.
Posted May 13, 2025 - 16:10 BST