Account balance updates: delays expected
Incident Report for Tide
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 09:49 GMT
Investigating
Your account balance might not be updating on your app timeline.

If your balance hasn’t updated properly, don’t repeat any payments yet. Your balance will refresh and update in up to 2 hours.

We’re fixing the delays, but please expect this issue to continue over the weekend, until Monday 20 November.

We apologise for the inconvenience and thank you for your patience over the next few days.
For urgent balance queries, tap ‘Support’ in your app.
Posted Nov 17, 2023 - 14:43 GMT
This incident affected: UK Tide App.