Some Outbound Payments are not going through at the moment.

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 16:27 BST

Update

Resolved: All Outbound Payments are going through normally.

If your Outbound Payment failed earlier, you can retry it now.

Thanks for giving us the time to resolve this.
Posted Apr 28, 2025 - 16:26 BST

Investigating

If your Outbound Payment has failed, please don’t retry until we’ve resolved this.

Check back here for updates – we’ll let you know as soon as things are back to normal.

Thank you for your patience, we apologise for any inconvenience.

Tap ‘Support’ in the app if you need us.
Posted Apr 28, 2025 - 15:38 BST