Outbound Payments queued

Incident Report for Tide

Resolved

The issue has been resolved and all queued payments have been processed successfully.

Thank you for your patience. We apologise for any inconvenience this may have caused.
Posted Jun 09, 2025 - 14:31 BST

Investigating

Outbound domestic Payments are currently being queued while we fix a recent issue. Payments will go through as soon as we’ve resolved this.

Please do not reattempt any payments. For urgent issues, tap Support in the app.
Posted Jun 09, 2025 - 14:00 BST