Degraded Performance - Payments Outbound and Direct Debits
Incident Report for Tide
Resolved
Managing Direct Debits was also resolved.
Posted Jan 31, 2024 - 20:32 GMT
Update
We've resolved the issues affecting payee creation and you can now make payments as normal.

There is one remaining issue affecting managing of direct debits.

You won't be able to manage your direct debits in your app, but your already set-up direct debits due tomorrow will be collected.
Posted Jan 31, 2024 - 18:59 GMT
Update
As a temporary measure, you can’t create new payees at the moment. This pause is helping us to process any queued payments to existing recipients. Direct Debit management is still not working.

Thank you for your patience while we get back to normal.
Posted Jan 31, 2024 - 17:01 GMT
Update
We are continuing to investigate this issue.
Posted Jan 31, 2024 - 15:06 GMT
Investigating
We’re experiencing a problem that’s impacting a number of our services including:
- Outbound Payments
- Direct Debit management
- Creating Payees
- Registering for a Tide account

Payments may still go through, even if the app says there’s been an error, so please double check the timeline in your app before trying to make a payment again.

We’re looking into the cause of these problems and hope to resolve them quickly.

For urgent issues, or if you are unsure if a payment has gone through, tap ‘Support’ in the app.
Posted Jan 31, 2024 - 13:21 GMT
This incident affected: Making Payments (UK).