EUR SEPA is currently unavailable through Tide on the web.
Incident Report for Tide
Resolved
The issue has been resolved and the EUR SEPA functionalities can be accessed on the web.
Posted Oct 17, 2024 - 10:02 BST
Identified
EUR SEPA is currently unavailable through Tide on the web.

If you’d like to make a EUR SEPA payment, you can still do so through your Tide app.

We'll provide an update here as soon as it is back online.

Thank you for your patience,

Team Tide
Posted Oct 16, 2024 - 17:53 BST
This incident affected: UK Tide on the Web and Making Payments (UK).