Adding Money via Cards or Digital wallets

Incident Report for Tide

Resolved

Adding Money via Cards or Digital wallet is available again

Thanks for your patience, and we’re sorry for any disruption this caused.

Tap ‘Support’ in the app if you have questions or need assistance.
Posted Apr 06, 2026 - 11:42 BST

Investigating

We're experiencing an issue with adding Money via Cards or Digital wallets.

We had to temporarily disable it until Monday morning.

If you have any questions, tap 'Support' in the app.
Posted Apr 05, 2026 - 19:25 BST