Inbound and Outbound payments are currently delayed

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Jun 25, 2024 - 12:45 BST

Investigating

We are currently investigating this issue.
Posted Jun 25, 2024 - 12:37 BST
This incident affected: Making Payments (UK).