EUR SEPA payments unavailable

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 06:32 GMT

Investigating

We’re experiencing issues with outbound EUR SEPA payments.
We apologize for any inconvenience.
We'll update this page once service is restored
Posted Mar 09, 2025 - 21:58 GMT
This incident affected: Making Payments (UK).