Delay in processing documents

Incident Report for Tide

Resolved

Thanks for your patience while we sorted this.

We're now able to process documents as part of onboarding and account recoveries.
Posted Jan 07, 2026 - 16:16 GMT

Investigating

We’re experiencing an issue in processing documents as part of onboarding and account recoveries.

We’re addressing the problem with our partner, who is having these issues - thank you for your patience.

We’re very sorry for the disruption, and we’ll keep you updated on this page.

For urgent queries, tap 'Support' in the app.
Posted Jan 07, 2026 - 15:13 GMT