Resolved: Some Outbound and Inbound payments were held in a queue temporarily.

Incident Report for Tide

Resolved

We’ve resolved this quickly and all payments are now going through normally – no need to retry any payments.

We're sorry for the inconvenience. Tap 'Support' in the app if you need to get in touch.
Posted Apr 15, 2025 - 09:58 BST
This incident affected: Making Payments (UK).