Members may face delays with inbound payments being processed

Incident Report for Tide

Resolved

All inbound payments should now be processed without a delay.
Posted Aug 02, 2024 - 12:23 BST

Update

Error

We’re experiencing an issue with Inbound payments - they are being queued and will go through with a delay.

We’re fixing this as quickly as we can, and we’re sorry about any inconvenience.

If you have any questions, tap ‘Support’ in the app.
Posted Aug 02, 2024 - 11:26 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 02, 2024 - 11:03 BST

Investigating

We are currently investigating this issue.
Posted Aug 02, 2024 - 11:03 BST
This incident affected: UK Tide App and Making Payments (UK).