Platform issues: Resolved

Incident Report for Tide

Resolved

We’re back to normal and you can now:

Make Outbound Payments
Confirm Payees
See your Direct Debits in the app
Use your Tide card
Create a new Tide account

If any of your payments failed earlier, you can retry them.

Thank you for giving us the time to resolve this – we appreciate your patience.

Once again, we apologise for any inconvenience this may have caused.
Posted Aug 01, 2025 - 10:44 BST

Investigating

At the moment you may not be able to:

Make Outbound Payments
Confirm Payees
See your Direct Debits in the app
Create a new Tide account

We’re working to resolve this as fast as we can - please check back here for updates.

For urgent issues tap ‘Support’ in the app.
Posted Aug 01, 2025 - 09:07 BST