Temporary issues with chats and phone calls

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 15:37 BST

Investigating

We're facing a problem at the moment, where some members can't get through to us over chat or on the phone.

We're looking into what's causing this and will update this page as soon as you can try to reach out.

For urgent queries, email hello@tide.co.

Apologies for the inconvenience.
Posted Jun 09, 2026 - 15:06 BST