Degraded Performance - Tide
Incident Report for Tide
Resolved
We have now restored the Tide service. You should now be able to login and use Tide as usual.

We apologise for this impact on your Tide experience, thank you for your patience.
Posted Nov 22, 2021 - 21:36 GMT
Update
We are continuing to work on a fix for this issue.
Posted Nov 22, 2021 - 21:34 GMT
Identified
We are aware and investigating an issue affecting:
- Making payments
- Up to date account timeline information
- New account creation

We apologise for this interruption and are working to bring this back as quickly as possible.
Posted Nov 22, 2021 - 21:06 GMT
Investigating
We're experiencing an issue affecting our Tide platform.

You may be experiencing problems using the application.

We are currently looking into the issue.
Posted Nov 22, 2021 - 20:16 GMT
This incident affected: Tide on the Web, New Member Sign-up, Making Payments, and Tide App.