Creating invoices
Incident Report for Tide
Resolved
The issue has been identified and fixed.
Invoicing is working as normal on both the Mobile app and the Web app.
Posted Feb 05, 2024 - 12:29 GMT
Investigating
We have indentified an issue with the Create invoices process that the team are working on. Please bear with us whilst we work on resolving this problem.
Posted Feb 05, 2024 - 12:01 GMT
This incident affected: UK Tide App and UK Tide on the Web.