Degraded performace

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Jan 21, 2025 - 10:17 GMT

Investigating

Some members can’t log in to the app or Tide on the web.

We’re fixing this - please check back here for further updates.

For urgent queries, tap ‘Support’ in the app, or email hello@tide.co.

We apologise for the inconvenience.
Posted Jan 21, 2025 - 09:24 GMT
This incident affected: UK Tide App.