Company registration and Confirmation Filling delay

Incident Report for Tide

Resolved

You can now continue to register your company or issue a Confirmation Filling to Companies House.
Thank you for your patience while we got things back to normal.
Posted Mar 02, 2026 - 14:56 GMT

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 14:35 GMT

Investigating

We're currently experiencing a delay in issuing personal codes for new and existing users, looking to register their company or issue a Confirmation Filling to Companies House.
We're working to resolve this and will update this page when we can help you issue your personal code.
Apologies for the inconvenience.
For urgent queries, tap 'Support' in your app and we'll help you.
Posted Mar 02, 2026 - 13:47 GMT